DOKUMANISTAN.COM
|| İÇERİK

Excelde iki Tabloyu Birbirine Bağlama İşlemi

Soru Cevap Bölümü
|| İÇERİK

HÜSEYİN GÜLER sordu

Excel Soruları

Kolay Gelsin. Excel de bir tane tablom var örnek şablonumu yükleyebilsem çok daha kolay olacak anlatmam fakat imkan olmadığı için basitçe örnek vereceğim. sayfa 1’de üst taraf başlıklar yazıyor. A1: adı soyadı B1: şehir C1 den G1 e kadar Gün 1 Gün 2 Gün 3 Gün 4 diye gidiyor.

A1 in altında Ahmet Mehmet Ali Veli diye 4 tane isim aşağıya doğru sıralanmış
B1 in altında da aydın Ankara İstanbul Kayseri diye 4 tane şehir aşağıya doğru sıralanmış.
C2-G2 de aşağı sütunlar. böyle bir tablo düşünün.

Sayfa 2 de de farklı bir tablo var. bu tablo da da a1:günler başlığı altında A2:Gün1  A3:Gün2  A4:Gün3 A5: Gün 4 diye aşağıya doğru sıralanıyor.
B1 de adı Soyad C1 de de Sehir başlıkları yazıyor. (B2-C5) sütunları da boş durumda. yani Sayfa 1 deki tablonun yatay-dikey yer değiştirilmiş hali.

Size sormak istediğim şu; sayfa 1de gün1 hücresini altındaki sütunlardan herhangi bir hücreye x koyduğumda onun satırına denk gelen adı soyadı sütunundaki hücrenin sayfa 2 deki gün1 hücresinin yanındaki adı soyadı hücresine yazsın, Şehrini de gene gün1 in aynı satırındaki şehir hücresine yazsın.

Aynı şekilde Sayfa 1 de gün2 altındaki herhangi bir sütuna x koyduğumda o satırdaki ad soyad ve şehir bilgilerini sayfa 2 deki gün 2 satırındaki ad soyad şehir hücrelerine aktarsın istiyorum. umarım yeterince açıklayabilmişimdir sorumu. şimdiden teşekkür ederim.

 

Excel Cevapları

 

Merhabalar;

Anladığım kadarıyla, Sayfa1’de aşağıdaki gibi bir tablo

ADIŞEHİRGÜN1GÜN2GÜN3GÜN4GÜN5
AHMETAYDINX
MEHMETANKARAX
ALİİSTANBULX
VELİKAYSERİ

 

Sayfa2’de de aşağıdaki gibi bir tablo kullanıyorsunuz.

GÜNLERADI SOYADIŞEHİR
GÜN1
GÜN2
GÜN3
GÜN4

Sayfa2’de de kesişen yerlere Sayfa1’de elde ettiğiniz verilerin getirilmesini istiyorsunuz.

Ancak Sayfa1’de hazırladığınız tablonun formatını biraz değiştirebilirseniz DÜŞEYARA ile istediğiniz sonuca ulaşabilirsiniz. Şöyle ki GÜN’lerin altına X koymak yerine aşağıdaki gibi GÜN1, GÜN2 gibi değerleri yazabilir misiniz. Birde günler en başta olmalı.

GÜNLERADIŞEHİR
GÜN1AHMETAYDIN
GÜN1MEHMETANKARA
GÜN2ALİİSTANBUL
GÜN2VELİKAYSERİ

Eğer Sayfa1’deki verileri bu şekilde girerseniz DÜŞEYARA formülü ile verileri istediğiniz gibi verileri getirebilirsiniz.

Sayfa2 B2’deki formül aşağıdaki gibi olmalı

=DÜŞEYARA(A2;Sayfa1!$A$10:$C$14;2;0)

Selamlar.

Mustafa ÇETİN
Mustafa ÇETİN

Yorumlar - Excelde iki Tabloyu Birbirine Bağlama İşlemi için

Yorum bırakın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir

This site uses Akismet to reduce spam. Learn how your comment data is processed.