DOKUMANISTAN.COM

Soru Sor

DOKUMANISTAN > Soru Sor
0
0

Selam üstad bana gönderdiğiniz örnek ışık tuttu teşekkürler.
Fakat sizin örnekte şöyle anladım;
İlk eğerli parantezi her bastığımızda adım adım değerlendiriyor en sonunda formülde sorun yoksa “DOĞRU”
formülde sorun varsa “YANLIŞ” yazıyor
Ama şunu anlamadım; B2=A;1….B2=B;2….B2=C;3… B2=D;4… B2=E;5…B2=F;6…..B2=G;7
ilk eğerde g=a nasıl oluyor onu anlamadım

Bizim elemanlar hafta içi 08:30 giriş 18:30 çıkış C.tesi 08:30 giriş 13:00 çıkış
aşağıdaki formülde mesai saatlerini hesaplamak için yazdım ama sonucu döndürmüyor sadece pazar günlerini döndürüyor rica etsem düzeltebilirmisiniz. İsterseniz ilgili exel sayfasını atabilirim ama dosya ekle butonunuzu göremedim

=EĞER(VE(HAFTANINGÜNÜ(A2;2)>=1<7;C2=F2);((D2-C2)+(G2-F2)+(E2));EĞER(HAFTANINGÜNÜ(A2;2)=7;G2-C2+E2;0))

 

Excel Dosya Download Makalede kullandığımız çalışma kitabını buradan indirebilirsiniz.

 

  • Yorum yapabilmek için yapmanız gerekli
0
0

Ergül Bey Merhabalar;
İlk baktığımda formülünüzde hata görüyorum.
VE(
1. Mantıksal : HAFTANINGÜNÜ(A2;1)>=1<7;
2. Mantıksal : C2<=D2;G2>=F2);
3. Mantıksal : ((D2-C2)+(G2-F2)+(E2)
)

1. Mantıksal’da;
=’den sonrasında 1>7 yapmışsınız. Bu işlemde Mantıksal işlem yapmış oluyorsunuz. Ancak HAFTANINGÜNÜ formülünden çıkan sonuç 7 çıkıyor. Yani
7 ile DOĞRU kelimesini karşılaştırıyorsunuz. 7 – DOĞRU’ya eşit olmadığı için YANLIŞ değeri döner.

2. Mantıksal’da;

C2<=D2 derken gönderdiğiniz excel’de GİRİŞ değerindeki veri tipi ile MESAİ BAŞLANGICI değerinin veri tipleri aynı değil. Biri Giriş Sayı tipinde iken Metin Başlangıcı Metinsel D3 hücresindeki formülde yazdığınız “08:30” işlem verinin tipini değiştiriyor. Tırnak içinde yazılan değerler metinsel olur.
G2>=F2 Aynı durum bu işlemde de var. Veri Tipi Uyumsuzluğu
3. Mantıksal’da,
(D2-C2) ve (G2-F2) kısımda yine veri tipi uyumsuzluğu var.

Bu kısımların analizini Formülü Değerlendir işlemine benzer bir işlem olan F9 tuşu ile yapar bilirsiniz. Bu tespitleri F9 tuşu ile yaptım. Uzun formülde hesaplayacağı alanı seçiyorsunuz. F9 tuşuna bastığınızda o anki değeri gösterir.

Mesela aşağıda bahsettiğim sorunu görebilirsiniz. Sayı ile metin değeri birbirinden çıkarılmaya çalışılıyor.

Formül Denetlemede F9 Tuşu Kullanımı

 

Tavsiyem bu hataları düzeltip kendi mantığınızda tekrar analiz edin. Böylece sorunu hem kendiniz çözmüş olacaksınız. Hem de F9 mantığını tam kavramış olursunuz.

Diğer taraftan Mesai hesaplaması yapmak istiyorsunuz. Ancak bakarken ilk formül hatalarından dolayı anlamlandıramadım. Eğer işin içinden çıkamazsanız aşağıda bana gönderdiğiniz tablodan nasıl bir işlem istediğinizin hikayesini bu bölümde belirtirseniz ona göre formülü yeniden geliştirebiliriz.

Mesai Saatleri Hesaplaması

Selamlar.

 

 

  • Yorum yapabilmek için yapmanız gerekli
1 sonuç gösteriliyor
Cevabınız
İsim*
E-mail*
Mustafa ÇETİN
Mustafa ÇETİN
Office Eğitmeni