İNDİS Formülü ile Aralıklarda Arama

Soru Cevap Bölümü
DOKUMANISTAN > İNDİS Formülü ile Aralıklarda Arama
1
0

Arkadaşlar selam.
İNDİS formülü ile belirli aralıklarda arama yapabiliyorum..
(Örneğin : =İNDİS(BİLGİLER!$A$8:$A$17;KAÇINCI(‘DENETİM PLN’!A7;BİLGİLER!$C$8:$C$17;0)) gibi..
Ancak arama yapmak istediğim aralık C8:C17 değil de C8:D17 olunca formül #YOK hatası veriyor.
Çözümü nedir?
Şimdiden teşekkürler

  • ŞERİF ALİ ŞENSAZLI sordu 1 sene önce
  • son düzenleme 9 ay önce
  • Yorum yapabilmek için yapmanız gerekli
0
0

Merhabalar;

Öncelikle formülün site takipçilerimizin tarafından daha iyi anlayabilmesi için soruyu sadeleştirip açıklamaya çalışayım.

Formülün Açıklaması

KAÇINCI  Formülü ile aradığınız değerin seçtiğiniz aralıkta kaçıncı sırada olduğunu belirlersiniz.

=KAÇINCI(Aranan Değer; Aranan Değer Aralığı;Tam Eşleşme)

KAÇINCI Fonksiyonu Örneği

İNDİS Formülü ile de verdiğiniz aralıktaki hangi değeri yazılmasını istiyorsanız aralıktaki sayıyı yazarsınız. Bu noktada KAÇINCI Formülü bu işi görüyor. Bu sebeple İNDİS ve KAÇINCI formülü aramalarda birlikte kullanılabilir.
İNDİS Fonksiyonu Örneği
Sonuç olarak belirttiğiniz formülün =İNDİS(B3:B12;KAÇINCI(B2;D3:D12;0)) şekilde değerlendirelim.

Sorunuza gelince;

KAÇINCI formülü aralık seçerken sadece yatay ve dikey tek boyutlu yani tek satır kullanabilirsiniz. İki boyutlu yani D3:E12 şeklinde kullanılırsa B kolonunda olsa dahi #YOK hatası verecektir. KAÇINCI Formülü tek kolon olarak tasarlanmıştır. Microsoft Office Sitesindeki Kaçıncı İşlevi açıklamasında da belirttiğiniz nitelikte bir örneğe rastlamadım.
KAÇINCI Fonksiyonu Sorunu Çözümü
Aradığınız değeri alt alta koyarsanız aramanız çalışacaktır.

  • Yorum yapabilmek için yapmanız gerekli
1 sonuç gösteriliyor
Cevabınız
İsim*
E-mail*
Mustafa ÇETİN
Mustafa ÇETİN
Office Eğitmeni