Excelde iki tabloyu Birbirine Bağlama İşlemi

Soru Cevap Bölümü
DOKUMANISTAN > Excelde iki tabloyu Birbirine Bağlama İşlemi
0
0

KOLAY GELSİN. EXCEL DE BİR TANE TABLOM VAR ÖRNEK ŞABLONUMU YÜKLEYEBİLSEM ÇOK DAHA KOLAY OLACAK ANLATMAM FAKAT İMKAN OLMADIĞI İÇİN BASİTÇE ÖRNEK VERECEĞİM.SAYFA 1’DE ÜST TARAF BAŞLIKLAR YAZIYOR. A1: ADI SOYADI B1: ŞEHİR C1 DEN G1 E KADAR GÜN1 GÜN 2 GÜN 3 GÜN 4 DİYE GİDİYOR.

A1 İN ALTINDA AHMET MEHMET ALİ VELİ DİYE 4 TANE İSİM AŞAĞIYA DOĞRU SIRALANMIŞ
B1 İN ALTINDA DA AYDIN ANKARA İSTANBUL KAYSERİ DİYE 4 TANE ŞEHİR AŞAĞIYA DOĞRU SIRALANMIŞ.
C2-G2 DE AŞAĞI SÜTUNLAR. BÖYLE BİR TABLO DÜŞÜNÜN.

SAYFA 2 DE DE FARKLI BİR TABLO VAR. BU TABLO DA DA A1:GÜNLER BAŞLIĞI ALTINDA A2:GÜN1 A3:GÜN2 A4:GÜN3 A5:GÜN4 DİYE AŞAĞIYA DOĞRU SIRALANIYOR.
B1 DE ADI SAYADI C1 DE DE ŞEHİR BAŞLIKLARI YAZIYOR. (B2-C5) SÜTUNLARI DA BOŞ DURUMDA. YANİ SAYFA 1 DEKİ TABLONUN YATAY-DİKEY YER DEĞİŞTİRİLMİŞ HALİ.

SİZE SORMAK İSTEDİĞİM ŞU; SAYFA 1DE GÜN1 HÜCRESİNİ ALTINDAKİ SÜTUNLARDAN HERHANGİ BİR HÜCREYE X KOYDUĞUMDA ONUN SATIRINA DENK GELEN ADI SOYADI SÜTUNUNDAKİ HÜCRENİN SAYFA 2 DEKİ GÜN1 HÜCRESİNİN YANINDAKİ ADI SOYADI HÜCRESİNE YAZSIN,ŞEHRİNİ DE GENE GÜN1 İN AYNI SATIRINDAKİ ŞEHİR HÜCRESİNE YAZSIN.

AYNI ŞEKİLDE SAYFA 1 DE GÜN2 ALTINDAKİ HERHANGİ BİR SÜTUNA X KOYDUĞUMDA O SATIRDAKİ AD SOYAD VE ŞEHİR BİLGİLERİNİ SAYFA 2 DEKİ GÜN 2 SATIRINDAKİ AD SOYAD ŞEHİR HÜCRELERİNE AKTARSIN İSTİYORUM. UMARIM YETERİNCE AÇIKLAYABİLMİŞİMDİR SORUMU. ŞİMDİDEN TEŞEKKÜR EDERİM.

  • HÜSEYİN GÜLER sordu 3 ay önce
  • son düzenleme 4 hafta önce
  • Yorum yapabilmek için yapmanız gerekli
0
0

Merhabalar;

Anladığım kadarıyla, Sayfa1’de aşağıdaki gibi bir tablo

ADIŞEHİRGÜN1GÜN2GÜN3GÜN4GÜN5
AHMETAYDINX
MEHMETANKARAX
ALİİSTANBULX
VELİKAYSERİ

 

Sayfa2’de de aşağıdaki gibi bir tablo kullanıyorsunuz.

GÜNLERADI SOYADIŞEHİR
GÜN1
GÜN2
GÜN3
GÜN4

Sayfa2’de de kesişen yerlere Sayfa1’de elde ettiğiniz verilerin getirilmesini istiyorsunuz.

Ancak Sayfa1’de hazırladığınız tablonun formatını biraz değiştirebilirseniz DÜŞEYARA ile istediğiniz sonuca ulaşabilirsiniz. Şöyle ki GÜN’lerin altına X koymak yerine aşağıdaki gibi GÜN1, GÜN2 gibi değerleri yazabilir misiniz. Birde günler en başta olmalı.

GÜNLERADIŞEHİR
GÜN1AHMETAYDIN
GÜN1MEHMETANKARA
GÜN2ALİİSTANBUL
GÜN2VELİKAYSERİ

Eğer Sayfa1’deki verileri bu şekilde girerseniz DÜŞEYARA formülü ile verileri istediğiniz gibi verileri getirebilirsiniz.

Sayfa2 B2’deki formül aşağıdaki gibi olmalı

=DÜŞEYARA(A2;Sayfa1!$A$10:$C$14;2;0)

Selamlar.

 

  • Yorum yapabilmek için yapmanız gerekli
1 sonuç gösteriliyor
Cevabınız
İsim*
E-mail*
Mustafa ÇETİN
Mustafa ÇETİN
Office Eğitmeni